Not signed in (Sign In)

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    This one is stale, but I had a similar issue that I'm looking to solve now, when upgrading from 1.03b3 to 1.0RC1, on 117 out of 3,000-some images. No matter how many times I try to let upgrade.php finish moving images to their new directories, I get:

    Plogger was unable to move the following images. Please check your permissions.

    ?Could not move file: /home/username/public_html/.../file1.jpg
    ?Could not move file: /home/username/public_html/.../file2.jpg
    ?Could not move file: /home/username/public_html/.../file3.jpg

    Permissions on the directories in question seem fine and consistent with all the others I have, and reapplying those permissions didn't help (755 on the directories and 644 on the files is what I tried, which was consistent with how the rest were). All 117 unmovable images are in only two directories. I was able to move other files after encountering the problem, so I don't think user permissions on the SQL database are the issue (which I just set up for full control of the DB after moving stuff from another Web host).

    It could be notable that all of the "problem" files are in subdirectories with names having two underscores in a row at some point (which originally were some character Plogger doesn't like and then a space, or vice versa, and Plogger changed it to two underscores back in v. 1.03b). I'm not sure if this is significant, but I think it must be something weird like that causing the issue.</p>

    Does anyone have a solution I could implement? Going back to upgrade.php doesn't work--still can't move the files. If there is something I can do to manually move the files and make sure Plogger still works properly, I'll give it a try, but I don't want to mess it up.
    • CommentTimeFeb 4th 2010

    Try setting your old folder and file permissions to '777' and try the upgrade process again (the new folders and files should not have open permissions after the transfer, so you shouldn't have to worry about a security hole). If that still doesn't work, I'll look at the code again and see if there are some possible path issues.
    I had already tried applying 755 to all the source files and directories, but I just tried 777, per your advice--still no luck. Thanks for the idea. Is there something else I can do?
    FYI, I don't think underscores in the folder names are the issue, since those abound elsewhere where I had no problems. It's actually three directories in which these files reside, which are subdirectories of other folders in /images. It doesn't seem to be the length of the overall path name, because longer paths were not an issue for other images that were successfully moved. Hmmm....
    • CommentTimeFeb 4th 2010 edited

    Are the file paths correctly shown in the error message (i.e. "Could not move file: /home/username/public_html/.../file1.jpg" - Does file1.jpg's path match that of the old, non-upgraded file path)?
    Also, is there a new folder created on the system with a similar-named directory (using hyphens instead of underscores)?
    Thankful People: hotshot309
    • CommentAuthorhotshot309
    • CommentTimeFeb 5th 2010 edited
    Hi Sid,

    I think we're definitely getting there. I overlooked a major point in the first place. What it says is:

    Could not move file: /.../plogger1b3_rev549/parentdirname/subdirname/filename.jpg

    (that's the old path, where the original file is), whereas it should be moving images from


    to the new folder created during the upgrade to 1.0 RC 1:


    So there is something not working properly there. In reply to your second question--the original (source) directories are named as follows:



    and their new counterparts are

    (note the period at the end of the first sudirectory's name)

    /.../plogger1b3_rev549/plog-content/images/information-technology-gearetc./my-new-desktop-system-build-1-may-2007 (again, note the period)

    /.../plogger1b3_rev549/plog-content/images/new-yorkny/140-metropolitan-ave. (another period here)

    When I set up the folders in the first place, I probably had periods written in these places, but Plogger 1 Beta 3 Rev. 549 replaced them with underscores. During the upgrade to 1.0 RC 1, the periods were apparently put back where I originally had them. So this could well be the problem. I also went through all the other image directories and found that only one other one still had a period in it (in both the old and new directories), but that period was not at the end of the path's name, so maybe that's why it didn't prevent the moving of the images.

    Let me know if you figure out what my next step should be. Thanks again for all your help.
    • CommentAuthorhotshot309
    • CommentTimeFeb 12th 2010
    Does anyone have any suggestions or ideas? @sidtheduck, I really appreciate all your help to this point.
    • CommentAuthorhotshot309
    • CommentTimeFeb 18th 2010
    I am going to start a new post for this--perhaps refreshing it will help find some answers.
    • CommentTimeFeb 18th 2010
    Sorry, hotshot309, I got busy these past few days,

    It may be the period that is throwing it off, but it also looks like the original path is messed up (as you noted, the "images/" directory is missing). Looking at the code, it looks like this would happen if the database has a listing of it, but it cannot find the images along the old pathways.

    Is there any way I can get temporary FTP access to do some testing and to verify the directory structure to see if I can see what is going on? If so, you can email me at sidtheduck AT gmail DOT com
    • CommentAuthorsuz
    • CommentTimeFeb 19th 2010 edited
    I have the same problem with only one image. The URL path is wrong:

    ?Could not move file: /home/********/**********/fixmix/galeria/fanarts/tv_movies/3watch.jpg

    and must be


    But in the images/fanarts/tv_movies folder doesnīt appear any images.

    Some ideas?? Thanks!! ^^
    • CommentAuthorhotshot309
    • CommentTimeFeb 19th 2010
    Sidtheduck and I fixed this today. It was actually pretty easy. If you are comfortable editing a PHP file, I know what he had me do, which worked. Or sid can respond, since he's the developer....
    • CommentAuthorsuz
    • CommentTimeFeb 20th 2010
    @ hotshot If you remember what need to do I really appreciate if you tell me, because maybe sid is very busy. If is easy, i think i can edit a PHP file :)
    This is my mail suzanmx AT hotmail DOT com
    Or give me yours and i can write you.
    • CommentAuthorsuz
    • CommentTimeFeb 22nd 2010
    Hi again, sorry for post again, but i canīt resolve my problem, so, someone can tell me wich PHP file i need to edit and what to do it??

    Thanks!!! ^^
    • CommentTimeFeb 22nd 2010
    Posted By: hotshot309Sidtheduck and I fixed this today. It was actually pretty easy. If you are comfortable editing a PHP file, I know what he had me do, which worked. Or sid can respond, since he's the developer....
    hotshot309's issue had to do with the collection or album name having a period in the name. It seems the old Plogger paths removed the period and the new ones do not. I'm still looking into why it hit the issue, however, but hotshot309's fix was to rename the old Plogger directory to have a period at the end (to match the returned error message path).

    Posted By: suzBut in the images/fanarts/tv_movies folder doesnīt appear any images.
    suz, your issue looks like you are missing an image that is still in the database. Plogger is trying to move the file, but the file no longer exists (not sure how or when it was deleted, but it does not appear to be there). If you have a copy of the image somewhere, just upload the image (with the same name as the error you are getting: "3watch.jpg") to the directory and it should find it just fine during the upgrade process.
    Thankful People: hotshot309, suz
    • CommentAuthorhotshot309
    • CommentTimeFeb 23rd 2010
    Thanks, @sidtheduck.

    More specific info on the fix that worked for me: We made a small change to the php-functions file (I've forgotten its exact filename) which caused the script to look in the source (old) /images directory, whereas it had left "images/"out of the path for the files it was unable to find and move. This worked, but the second issue was that the script was also inserting some periods at the ends of a couple directory names it was apparently searching for--and I'm referring to source directories here. The periods made sense, in context--they were placed at the end of the words "ave" and "etc" in a couple directory names--and I think I must have put them in originally, but then when the directories were created, they were removed somehow. I don't really know, but it wasn't a random insertion of periods, I'm pretty certain.

    In the end, I simply renamed those source directories to include the periods at the end that the script was looking for, and it was finally able to move all the remaining image files to the new directory structure and rename them.

    I think @sidtheduck is trying to find and fix the cause for this, but I thought I would put that out there in case it helps anyone else troubleshoot.
    Thankful People: suz
    • CommentAuthorsuz
    • CommentTimeFeb 25th 2010
    I will do that Sidtheduck and come back to tell if works ^^
    • CommentAuthorsuz
    • CommentTimeFeb 26th 2010
    I fixed it!! I only created a path where the database was searching, fanarts > tv_movies > 3watch.jpg and works. The weird is that i made this a few days ago and didnīt work and now fixed the problem ^^
    Thank you so much!!!
    • CommentAuthorjcaines
    • CommentTimeMar 26th 2011
    Hi there,
    Can anyone point to the fix for this in detail?? If it's in the plog.functions.php file - what parts need to be changed in detail? My upgrade is returning this error: Plogger was unable to move the following images. Please check your permissions.

    I see that it isn't creating the "images" directory.

    Does anyone have a detailed fix for this?