Not signed in (Sign In)

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorBewitched
    • CommentTimeNov 21st 2009 edited
    Well, I have tried that trick with
    if ($GLOBAL['plogger_level']=='collections' || $GLOBAL['plogger_level']=='collection' ) {
    $GLOBALS['plogger_level'] = 'album';
    $GLOBALS['plogger_id'] = #; // Enter the id# of the album here

    [more code goes here]

    <?php the_gallery_head(); ?>

    [more code goes here]

    <?php the_gallery(); ?>

    But my web site is getting confused with "if ($GLOBAL['plogger_level']=='collections' || $GLOBAL['plogger_level']=='collection' ) {" and doesn't work with it properly. I've tried this too:
    <?php include('www.mywebsite/plogger/?level=album&id=1');?>
    It worked but after I click on the thumbnail it "leaves" my design and appears in the blank page. I've tried to modify header and footer of my skin, but this ruined my design somehow (and I couldn't fix it).

    I have figured out that <?php the_plogger_gallery(); ?> works perfectly but doesn't allow me to include specific album or collection. So is there any possibility to modify this peace of code to do this thing?

    • CommentTimeNov 24th 2009

    It should be:
    if ($GLOBALS['plogger_level']=='collections' || $GLOBALS['plogger_level']=='collection' ) {
    note the 'S' on the end of $GLOBALS. Sorry if that was posted somewhere and you copied and pasted incorrect code (let me know if you did find it somewhere and I can edit the post).
    • CommentAuthorAJ28
    • CommentTimeSep 28th 2010
    Doh! I've been looking for this answer everywhere!! After having seen it originally in this post: embedding-a-single-collection-or-album and tearing my hair out cause it would not work, this makes it much better.

    I am however now getting:

    No Albums

    Sorry, but there are no images or albums in this collection yet.

    Any helpful pointer would be much appreciated.
    • CommentAuthormetafarion
    • CommentTimeFeb 27th 2011
    I, too, am having this problem with an embedded plogger gallery. I've set $GLOBALS['plogger_level'] and $GLOBALS['plogger_id'] to open a specific album and it seems to half work; the album title appears correctly, but no images appear.

    Instead, I see the "No Images" "Sorry, but there are no images in this album yet." messages when there are certainly images in the album. Is there another variable that needs setting to make this work?