Not signed in (Sign In)

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorTextronics
    • CommentTimeDec 16th 2005
    I am new to plogger so you be getting loads of questions. I uploaded everything and followed the instructions to the letter. I have a test album and inserted 2.jpg's and 1.gif for testing purposes. the thumbnail pics just show red "x",(just like when you insert a pic in a web page but the pic does not exist).if you click through them the pic pic actually shows,the thumbnail does not. Can anybody help......
    • CommentAuthorddejong
    • CommentTimeDec 16th 2005
    Do you have GD installed? It's the graphics manipulation library for PHP. Without it, Plogger cannot manipulate the images to generate and save thumbnails.

    • CommentAuthorTextronics
    • CommentTimeDec 16th 2005
    no .. did not know I needed it .. where do i get it or is it on the server?
    • CommentAuthorTextronics
    • CommentTimeDec 16th 2005
    found the answer , but don't understand what i have to do?? sorry if i am being thick !!
    • CommentAuthorTextronics
    • CommentTimeDec 16th 2005 edited
    I created a phpinfo script and saved in on the server and run it as per :

    got the result:

    GD Support enabled
    GD Version bundled (2.0.28 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled
    XBM Support enabled

    so i presume that it is enabled ...yes ??

    So what do i have to do to see my thumbnails?


    • CommentAuthorTextronics
    • CommentTimeDec 19th 2005 edited
    solved it by starting from scratch and recreating the database, reinstalled plogger (beta2.1), applied the permissions ...... i worked.

    fantastic script ..many thanks
    • CommentAuthormunra
    • CommentTimeDec 21st 2005 edited
    I'm running into exactly the same problem...

    I've reinstalled fresh and don't get any notice that I need to chmod anything, so I would have assumed that all the permissions would have been set correctly. Yet nothing gets generated into my thumbs directory. Is there anything that I can check to see if it's working or not?
    • CommentAuthorTextronics
    • CommentTimeDec 21st 2005
    What i did is ...

    Logged onto the webadmin site of my domain account. (My isp account)

    I then set all the permissions manually for every file and folder.

    After this...... everything worked. Make sure you check the security permissions.

    Tick all the boxes ..... My ISP told me they did everything too...

    But they did'nt .....

    I hope this helps ...
    • CommentAuthorminhas_amar
    • CommentTimeDec 21st 2005 edited
    to start with don't assume .... go ahead and check the permissions for
    "upload", "thumbs" and "images" and for the file "plog-config.php"... if not 777 then chmod it...
    • CommentAuthormunra
    • CommentTimeDec 21st 2005
    Very good point. In point of fact, I'd used my FTP client to set all three of those folders to 777 just to be sure. Textronics, I also checked with my host and, wouldn't it figure, they don't provide an online means of setting permissions. My FTP client is consistent in reporting permissions on the directory as 777, though. Does anybody think there's any utility in changing the permissions on files as well? I can write a script that'll spider through the site and change the permissions, but I'd rather not if I don't have to
    • CommentAuthormunra
    • CommentTimeDec 31st 2005
    For any interested folks, I implemented a different thumbnail script. It certainly isn't up to the task to revise the current head release, but if anybody else is having problems, feel free to email me david(at)munra(dot)net