Not signed in (Sign In)

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorhenryk
    • CommentTimeJun 11th 2010
    Hi guys,
    I just installed Plogger on my windows 2008 64bit server and everything with the installation went ok. After I upload a photo to an album I can see the thumbnail and everything looks ok but as soon as I click on the Thumb image it returns a URL like this: http://mydomain.comindex.php/?level=picture&id=5 it will show me the image if I add the / after the .com in the url.

    Any help?
    • CommentTimeJun 11th 2010
    On the Admin>Options page, when you enter the gallery URL in the General section, you are supposed to include the trailing slash (

    Check your setting for the gallery URL and make sure it has the trailing slash.

    If it does and you are still having this issue, let us know.
    • CommentAuthorhenryk
    • CommentTimeJun 11th 2010
    Thanks kimparsell but this settings are correct in the admin as I checked this first I am familiar with plogger admin area. The URL is correct in the admin section with the / at the end but still getting the issue. Any other suggestions?
    • CommentTimeJun 11th 2010
    Can you provide a link to your gallery install?

    Also, I'm assuming that you are running the latest version of Plogger (1.0-RC1) that is available for download from the website?
    • CommentAuthorhenryk
    • CommentTimeJun 11th 2010
    correct, I just removed plogger from my server. But can you maybe help me out without the live plogger install on my server? I am running windows 2008 64BIT server with Plesk Control panel so latest php fast-cgi mode and latest MySQL.

    Thank you
    • CommentTimeJun 11th 2010

    Try downloading the updated plog-load-config.php file from SVN here and replace your existing 1.0-RC1 file with that. There have been some additions to the base URL variable and Windows machines. Please try it out and let us know if you are still having issues.
    • CommentAuthorhenryk
    • CommentTimeJun 12th 2010
    sidtheduck, I tried the file but still no change. I am getting the url always without the/ after the .com it looks lie this: http://mydomain.comindex.php/?level=picture&id=2

    My admin setting have the / after the gallery url so it should work. Please, any help?
    • CommentAuthorkeg
    • CommentTimeJul 20th 2010
    Also running a windows server and have the same issue. Try to go to an album and the link is broken, no / between the gallery and the .com URL and my settings are correct in ADMIN and tried the updated config still no luck
    • CommentAuthorjmcpeak
    • CommentTimeJul 20th 2010 edited
    Wrong thread - sorry ---

    I tried the new plog-load-config.php file as well, no luck.

    It will not hold a session.

    Server Software: Apache/2.0.46 (CentOS)
    PHP Version: 4.3.2 (APACHE2FILTER)
    MySQL Version: 4.1.22
    GD Version: bundled (2.0.12 compatible) with JPEG support
    Session Save Path: /home/m/c/
    File Upload Size Limit: 2MB
    Temporary Memory Limit: 64M
    Code Run Time Limit: 300s


    • CommentAuthorcjdmax
    • CommentTimeSep 17th 2010 edited
    For some reason there is a slash missing from either _SERVER['HTTP_HOST'] or ['PHP_SELF']. Seen this before; probable IIS/PHP wonkiness

    check plog_load_config.php in the plogger root dir for the following code:

    if ($config['use_mod_rewrite'] == 1 && $config['embedded'] == 0) {
    $config['baseurl'] = 'http://'.$_SERVER['HTTP_HOST'].dirname($_SERVER['PHP_SELF']).'/';
    // otherwise just use our cleaned up version of $_SERVER['PHP_SELF'] from plog-globals.php
    } else {
    $config['baseurl'] = 'http://'.$_SERVER['HTTP_HOST'].$_SERVER['PHP_SELF'];

    edit both variable assignments to something like this:
    $config['baseurl'] = 'http://'.$_SERVER['HTTP_HOST']. "/" . $_SERVER['PHP_SELF'];
    • CommentAuthorhenryk
    • CommentTimeNov 22nd 2010 edited
    Hi cjdmax,

    Your solution WORKS. Thanks a lot now it works perfectly.

    Thank you
    • CommentAuthortwariq
    • CommentTimeOct 11th 2011
    Hello Plogger support team,

    First of all i want to thanks for the plogger developers who created such helpful tool for image gallery.

    Well i have installed plogger latest version plogger-1.0RC1. But the url is not showing correctly,

    it was showing like:

    Then i got one solution from Plogger Forum Toipc:

    By using this script i got "/" after my domain name, and now the link looks like this:

    But the actual problem is i have installed plogged in sub directory ""
    and in the above links the directory name is missing, i checked in plogged admin for gallery URL and its mentioned correctly as even after all this i am not able to fix this problem so please please please............... help me out how to fix this issue and to get the correct URL as :