Not signed in (Sign In)

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorjsdooley
    • CommentTimeOct 29th 2005

    I have just recently installed plogger on my website and got a similar error to "dude" so I applied the fix for it:

    Open up plog-functions.php and edit line 75. Change:
    $phpThumb->src = $source_file_name;

    I have done that and also replaced <? with <?php in the recommended files and now I get the following error:

    Failed: $AvailableImageOutputFormats = array(text;wbmp;gif;png;jpeg) in file "phpthumb.class.php" on line 519 $this->thumbnailFormat set to $this->config_output_format "jpeg" in file "phpthumb.class.php" on line 529 $this->thumbnailFormat staying as "jpeg" because "" ($this->f) is not in $AvailableImageOutputFormats in file "phpthumb.class.php" on line 539 $this->thumbnailQuality set to "75" in file "phpthumb.class.php" on line 546 $this->config_cache_directory () is not a directory in file "phpthumb.class.php" on line 587 SetCacheFilename() failed because $this->config_cache_directory is empty in file "phpthumb.class.php" on line 1815 EXIF thumbnail extraction: (size=5496; type=2; 160x120) in file "phpthumb.class.php" on line 1739 starting SourceImageToGD() in file "phpthumb.class.php" on line 1886 Not using EXIF thumbnail data because $this->config_use_exif_thumbnail_for_speed is FALSE in file "phpthumb.class.php" on line 1889 Calling ImageCreateFromJPEG(/www/j/jddesigncoma/htdocs/pix/uploads/DSC02381.jpg) in file "phpthumb.class.php" on line 1960 ImageCreateFromJPEG() was attempted but FAILED in file "phpthumb.class.php" on line 2001 Populating $this->rawImageData and attempting ImageCreateFromStringReplacement() in file "phpthumb.class.php" on line 2004 $this->gdimg_source is still empty in file "phpthumb.class.php" on line 2027 using ImageMagick path from `which convert` (/usr/local/bin/convert) in file "phpthumb.class.php" on line 702 ImageMagick was called as (convert -geometry 100x100 "/www/j/jddesigncoma/htdocs/pix/uploads/DSC02381.jpg" png:/www/j/jddesigncoma/htdocs/pix/admin/pThumbyrA2bg 2>&1) but failed with message (convert: Corrupt JPEG data: premature end of data segment `/www/j/jddesigncoma/htdocs/pix/uploads/DSC02381.jpg'.) in file "phpthumb.class.php" on line 765 ImageMagickThumbnailToGD() aborting because ImageMagickCommandlineBase() failed in file "phpthumb.class.php" on line 782 ImageMagickThumbnailToGD() failed in file "phpthumb.class.php" on line 2036 phpThumb() v1.6.0-200507180958 All attempts to create GD image source failed (source image probably corrupt), cannot generate thumbnail phpThumb() v1.6.0-200507180958 Unknown image type identified by "����" ( 0xff 0xd8 0xff 0xe1) in SourceImageToGD()

    The server that my site is on uses MySQL 4.1.7 , PHP Version 4.4.0
    with GD bundled (2.0.28 compatible).

    Please help!

    Many thanks
    • CommentAuthorjeff_man
    • CommentTimeOct 31st 2005
    I got this problem when importing, not uploading (serially). Actually, after getting this error, I was able to import a single file (proving the innards & security were probably not responsible).

    On the first pass, I moved about 50 images into the upload directory and it crashed, with the 'cannot generate thumbnail'.

    I deleted all the files and uploaded about 10 and it worked. Uploaded 15 and it worked. Obviously there's some magic number, likely related to memory, which causes this error.

    Of course, a batch load that has limitations should be spelled out or have a more elegant error catching mechanism.
    • CommentAuthorjsdooley
    • CommentTimeOct 31st 2005
    hi jeff_man,

    Oddly enough I had 15 images in the uploads folder so I deleted 5 so that 10 remained and the import worked! I never thought of minimising the number of images I had in the uploads folder as I was able to upload a single picture.

    Anyway mystery solved!

    Thanks a lot!