Not signed in (Sign In)

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorpandianbe
    • CommentTimeJun 21st 2009 edited
    When I include the Random and Latest Pictures plugins in my page,i am getting "mysql_error(): 8 is not a valid MySQL-Link resource" ?

    Please help to resolve this.

    Latest Trunk: r599

    Apache version 2.2.11 (Unix)
    PHP version 5.2.9
    MySQL version 5.0.77-community
    Architecture x86_64
    Operating system Linux
    • CommentAuthorpandianbe
    • CommentTimeJun 22nd 2009

    Please help this issue to resolve.
    • CommentTimeJun 23rd 2009

    I do not have any issue with these plugins.

    - Random Pictures -
    - Latest Pictures -

    Do you have a link to your install?
    • CommentAuthorpandianbe
    • CommentTimeJun 23rd 2009
    I found ...This is Becoz of Making Multiple connection with Mysql.

    I Just replace the below lines with - connect_db();

    //Database Connection
    //$connection = mysql_connect($host, $username, $password);
    //$db = mysql_select_db($database);

    Now it is working Properly and issue resolved.

    Why we are giving input everytime & connecting Mysql every time and not closing the connection? any Problem with this ?
    • CommentTimeJul 4th 2009
    pandianbe -

    The code you are showing in the above post is NOT in either of those plugins. Open plog-content/plugins/latest-images/latest-images.php and plog-content/plugins/latest-images/latest-images.php in a text editor, and you will not find that code in either file.

    However, that code IS in the OLD script written by theg3nius:

    The file that you edited is probably located in the root directory of your gallery, rather than in the respective plog-content/plugins folders for each plugin. You need to delete that script, as it is no longer required and can cause issues with the latest version of Plogger (hence your error). And, for the record, we are closing the database connections properly in the latest SVN version.

    If you navigate to the plugins tab in the admin section and click Use this plugin next to the plugins you want to use, you will be given the proper php include code to insert in the area of your website where you would like either random or latest images to be displayed.

    If you have any more questions about how to use the new versions of the plugins, please post them back here and either sid or myself will try to help you.
    • CommentAuthorpandianbe
    • CommentTimeAug 13th 2010
    Hi Kim and sidtheduck,

    I have included the corret path of the both plugins but Still I am getting the same DB error.

    <?php include('/home/xxxxxxxxx/public_html/gallery/plog-content/plugins/random-images/random-images.php'); ?>

    What could be the issue?

    Version Latest


    Warning: mysql_error(): 8 is not a valid MySQL-Link resource in /home/xxxxxx/public_html/gallery/plog-includes/plog-functions.php on line 551

    SELECT `p`.*, `a`.`path` AS `album_path`, `c`.`path` AS `collection_path` FROM `plogger_pictures` AS `p` LEFT JOIN `plogger_albums` AS `a` ON `p`.`parent_album`=`a`.`id` LEFT JOIN `plogger_collections` AS `c` ON `p`.`parent_collection`=`c`.`id` WHERE `p`.`id` = 18

    In file: /gallery/index.php

    On line: 778