Not signed in (Sign In)

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorphual
    • CommentTimeJun 16th 2010
    With an oodle of help, I was able to integrate Plogger into Textpattern as described here.

    However, we had a recent server issue which has left the gallery a bit of a mess. I thought that I'd take the opportunity to upgrade to 1.0-RC1 as I couldn't figure out what had happened to break the existing installation, so I moved it across to a new environment and performed the upgrade. Sadly it's causing a problem that I'm struggling to understand.

    I had to make a small addition to my .htaccess file, but the previous installation I used (revision 595) was giving me what I wanted from my URLs. However, post upgrade (and with no other changes at all), Plogger was presenting me with different URLs, which are causing a conflict with TextPattern.

    .htaccess addition (full details in the guide linked above):
    RewriteRule ^gallery/?$ /?s=gallery [QSA,L]

    Revision 595 urls:

    1.0-RC1 urls:

    I'm struggling to understand why 1.0-RC1 is giving me the different URL, and without being able to understand it I'm struggling even more to try and resolve it. Any thoughts?

    • CommentAuthorphual
    • CommentTimeJun 17th 2010
    A night's sleep has provided some progress, but my lack of php knowledge is still not allowing me to define a solution. The more I look at it, the more it looks like a bug.

    I can confirm that the problem is due to a change in plog-load-config.php around the greatly reduced $config['baseurl'] definition. I've tried overwriting the 1.0-RC1 plog-load-config.php with the file from SVN595, and this fixes the issue (although as you may expect, it breaks the site in other ways - an error with the undefined resize_option).

    Following this discovery, I performed a test. At line 100, I added the following code (lifted straight from an earlier version of the file):

    $url_parts = parse_url($_SERVER['REQUEST_URI']);
    $config['baseurl'] = 'http://'.$_SERVER['HTTP_HOST'].$url_parts['path'];

    This fixed the issue and got the site working fully again.

    Can anyone confirm that this should be raised as a bug?

    • CommentTimeSep 22nd 2010

    I remember this changed as a result of the previous code not working for some people, so it was changed to the current reduced definition (which seemed to work on almost all machines). This is the first I've heard of the new definition not working, so I'll take another look at the code and see if we can come up with something better.